[SOLVED] I am always getting this ad-block message when i am trying to access "onehack.us" even though my ad-block is turned off


1 Like

I use firefox and in that by default Enhanced Protection is turned ON, if you turn that off you won’t receive that message.

1 Like

I got same, I checked DNS address of network.
I was using AdGuard DNS server to block Ads.

hi, i am facing same problem, i m using microsoft edge,firefox and chrome. All same.Even after white listing on add blocker.

@sifuzi @minlaxz @k_p i face the same problem, clear the cookies and cache for last 7 days and remove adblock and used ublock and its works for me…

Check out this post for further information [SOLVED] Cant Access ONEHACK from my Laptop


Yep, I have removed AdGuard DNS address from my router. Now it is good, Thanks anyway.
Clear cookies is the best solution I think. I have also checked out here

Confirm if you are using mobile

1 Like

I’m unable to get the dark mode.!!! Does anybody else faces the same problem or am i missing something?

Idk why i am facing the same issue :thinking: I’ve turned off all the blocking extension including unlock . Still getting the same pop up msg.
Ps : using chrome

Use incognito mode (google is CTRL Shift N) and that resolved my problem, I am using PiHole and also experienced the same issue. So I did not have to disable nothing.

Just follow the above solution. Sign out remove cookies/cache try again, If you disabled ublock/adblocker, but still seeing the pop-up, just hit enter twice on the red mark, it will disappear.

You can also Whitelist onehack to avoid seeing that message.

Good luck! :+1:


not only adblocking extension blocks the ads. Some VPNs do block ads too. If you’re using NordVPN make sure you have disabled Cybersec option. Malwarebytes blocks ads too if you installed Malwarebytes extension in Chrome.


Thank you sam. It seems problem is solved.


I was having the same problem and none of the above suggestions helped. In the end I figured out it was to do with my hosts file. I have a lit of domains in my host file for personal reasons. Temporarily rename the hosts file to something else, then go to onehack; works perfect. When done, change the filename back. Hope this help anyone who is still having this problem.