Make your own Aria2 Torrent Leecher-Supports Direct upload to Gsuite & TD

Follow this steps :-

1 . Open heroku signup
Note: - select “Role” as "professional developer’ and primary language as “GO”.
(You can skip this step if you already have an account in heroku)
2 . Now do the mail verification and login to your account.
3. Now Click this Link.
4. Click the Deploy button (the one in purple).


5. Name the app whatever you like and also the RPC Secret as per your choice.
6. Click Deploy app.Thats it…done.
7. Click view app…and enjoy.

It supports direct upload to google teamdrive,Gsuite,Onedrive etc
You just need to enter rclone config and destination (name of the folder-in which it will be saved eg.downloads)
Ideally it should work for every host that rclone supports

  • But so far I have tried it with Gsuite and TD - Recommended

It doesn’t work with Onedrive well…slow upload speed and many issues…Do not use this with Onedrive

Steps:-

  1. Setup Rclone by following offical instructions: https://rclone.org/docs/. You need basic knowledge of rclone for direct upload to work.You can search On utube how to make rclone remote.Its super easy.If u already hv setup Rclone remote than u dont need to make new one

  2. Find your rclone.conf file, it should look like this inside it:

[DRIVENAME]
type = WHATEVER
client_id = WHATEVER
client_secret = WHATEVER
scope = WHATEVER
token = WHATEVER
team_drive =WHATEVER

others entries…
Find the drive you want to use, and copy its type = … to … token = … section/TD id (Incase of TD) and paste In rclone config tab of heroku.Do not paste the Config name…so many ppl saying its not working,
its not working bcoz u guys r pasting the config name “[DRIVENAME]” which is this in this example
You hv to follow my guide word to word coz even if u do any one small mistake it wont work

eg of what u hv to enter in heroku rclone config tab :-
type = WHATEVER
client_id = WHATEVER
client_secret = WHATEVER
scope = WHATEVER
token = WHATEVER
team_drive =WHATEVER

For rclone destination Tab of heroku u can name of the folder in which u want it to be saved (eg-Downloads)

Remember the Rpc secret u put when u r deploying in heroku…the app will ask the same password for login…without correct pw it will throw Authorization Failed error

For Rclone setup guide refer this

You dont need to create client id and secret in step 5 just press enter in step 6 and 7 it will pickup by default

For testing ur rclone config u can use

For Troubleshooting u shd do this:-
open heroku dashboard select ur app on top right side options select logs open app then put small file for testing…see logs simultaneously-it shd say uploaded in the logs at the end after it finishes downloading

Demo Image:-

Thats It-Enjoy

Please like my post if you find it useful.

46 Likes

Can you elaborate the process of adding rclone config file?

1 Like

did u create config file?Pm me for doubts i dont wanna spam the comment section :laughing:

3 Likes

Bro plz make a video tutorial plz Highly requested

6 Likes

ask me in pm what u dont understand. theres already many rclone utube tuts available…after that u just hv to put the config in heroku thats it

Thank Man I created it successfully

1 Like

need your help bro where is the location that set configuration to heroku

ask @FlashyFlash he helped me
Pm Him

where is the location of heroku app the to enter remote details

sry didnt get u…pm me
u hv to enter config when u deploy in heroku…if thats wat ur asking

I have set up rclone and configured with my Team Drive successfully. I tried to upload file via rclone-cli from my windows pc. It worked perfectly. Then I setup heroku app using that config. The app deployed successfully, starts and downloads item. But I can’t find the downloaded content on my Teamdrive. What can I do?

open heroku dashboard select ur app on top right side options select logs open app then put small file for testing…see logs simultaneously-it shd say uploaded in the logs at the end after it finishes downloading

I have created it but it is not showing in my google drive.

make sure ur rclone config is proper and correctly entered in heroku

i have did and i pasted this in rclone config line heroku.
I anything wrong in it?
[GoogleDrive]

type = drive

scope = drive

token = {“access_token”:“ya29.a0Adw1xeWXAVcg-yhAoQRTpCBB44sCLfoirq9of_bCKfCP6Sms8lxXGVPHaI9HdV17DXBmx-BBtIx2dwD28Mu-MDz5lUsjkadacnljkwnjdcdnuPYrZ_XZdtczE_6RxNwUfqPxFAM5BhFM”,“token_type”:“Bearer”,“refresh_token”:“1//03nu4mTdRZpmfCgYIARAAGAMSNwF-L9IrgOWNWYw1X0RedK53_hQ_jNwRFIrMUzDsMmLs4bqg7kFhwPde-fCqDlJovUAGf7e8RCU”,“expiry”:“2020-03-24T08:13:24.2846686+05:00”}

Can you send us screensot of that heroku depolyment page so we can see how you deployed it? and also rclone config one.

Dont paste ur rclone config like this u hv to keep it private like your password,its not safe anyone can access ur gdrive withur rclone config :laughing:
anyway install rclone browser and see if your config works and u can access and see ur files http://martins.ninja/RcloneBrowser/
I think u hv not configured rclone config properly
Pm me if u need detailed guidance lets not spam here :rofl:

1 Like

I know thats why I have change token config alphabets before sending it. Anyway, can you upload screenshots so i can get the configuration?

here step by step detailed rclone guide with pictures

thanks alot bro. issues got resolved

1 Like