Block Android Ads Without Installing an App

Everyone is bothered by the annoying ads specially on android and does most people do not want to install an ad blocker or buy its subscription, worry not cause I’m gonna tell you a method where you can block ads without installing any app. Keep this in mind this only works for android 9 or higher.
Step 1: go to your settings.
Step 2: Search for Private DNS.
Step 3: after selecting it a popup will appear, select the option Private DNS provider hostname.
Step 4: Write this in it “” without quotes.

It will block ads in any and every app.


Well, it did’nt work. Youtube ads were still popping and running like always :frowning:


I’ll give this a try. Thanks

Thank you. It works. There is no ads on my YouTube anymore. Lol :face_with_hand_over_mouth:

I still have ads on youtube is there something i’m missing. Using samsung galaxy m51.

1 Like

How did it worked for you? Not working for me! Am I missing something?

try restarting ur phone and check

try restarting ur phone and check…

Thanks Bro this is very useful.

Android: just apply in private DNS specified

Clear All data/ cache YouTube app

Restart your phone

No any ads will display on YouTube
That’s it.


How to use it in Android Tv ?


Thanks a lot.

not working

Update: Ads came back to both. If you clear cache and data without restart it will stay adfree for a bit but it comes back. Still super useful for in-app adds and browser so still thankful.

Thanks OP.

Ok so on initial try it was working on blocking in apps and browser great (which is awesome even without YT) but not Youtube or YT Music after only force stopping and clearing cache & a restart. Still showed ads but…

Went for broke cleared cache AND data in each apps settings, restarted and so far so good for YT Music I have skipped 50 songs but Youtube is still showing them. Not a big deal to me as I use music all day so big +

But try anyways:

Clear both completely and restart.

Me: Oneplus 10Pro Android 13

Thanks its works for me mx player

hi, try this :wink:


wow no popups! thank you!

1 Like

Let me try this one and will update you after a week.

Update: This one doesn’t seems to work :x:.

1 Like